Skip to main content
Version: 0.25

Version Compatibility Reference for Astronomer Software

Overview

Astronomer Software ships with and requires a number of adjacent technologies that support it, including Kubernetes, Helm, and Apache Airflow itself. This guide provides a reference of all required tools and versions for running Astronomer Software. This guide also includes a version compatibility reference table for running Astronomer Certified outside of the context of the Astronomer platform.

While the tables below reference the minimum compatible versions, we typically recommend running the latest versions of all tooling if and when possible.

Astronomer Software

Astronomer PlatformKubernetesHelmTerraformPostgresPythonAstronomer CLIAstronomer Certified
v0.231.16, 1.17, 1.1830.13.59.6+3.6, 3.7, 3.80.23.xAll
v0.251.17, 1.18, 1.19, 1.20, 1.213.60.13.59.6+3.6, 3.7, 3.8, 3.9 (requires AC 2.2.0+)0.25.xAll
v0.261.17, 1.18, 1.19, 1.20, 1.213.60.13.59.6+3.6, 3.7, 3.8, 3.9 (requires AC 2.2.0+)0.26.xAll
v0.271.18, 1.19, 1.20, 1.213.60.13.59.6+3.6, 3.7, 3.8, 3.9 (requires AC 2.2.0+)0.27.xAll
v0.281.19, 1.20, 1.213.60.13.59.6+3.6, 3.7, 3.8, 3.9 (requires AC 2.2.0+)0.28.xAll

For more detail on changes between Software versions, refer to Astronomer Software Release Notes.

Note: On Astronomer v0.23+, new versions of Apache Airflow on Astronomer Certified are automatically made available in the Software UI and CLI within 24 hours of their publication. For more information, refer to Available Astronomer Certified Versions.

Note: Due to the deprecation of Dockershim, Azure does not support private CAs starting with Kubernetes 1.19. If you use a private CA, contact Astronomer Support before upgrading to Kubernetes 1.19 on AKS.

Note: While Astronomer v0.25 is compatible with Astronomer Certified 2.2.0, support for the Airflow Triggerer is available only in Astronomer v0.26+. To use Deferrable Operators, which require the Airflow Triggerer, you must upgrade.

Kubernetes Version Support Policy

In general, Astronomer Software will support a given version of Kubernetes through its End of Life. This includes Kubernetes upstream and cloud-managed variants like GKE, AKS, and EKS. When a version of Kubernetes reaches End of Life, support will be removed in the next major or minor release of Astronomer Software. For more information on Kubernetes versioning and release policies, refer to Kubernetes Release History or your cloud provider.

For more information on upgrading Kubernetes versions, follow the guidelines offered by your cloud provider.

Astronomer Certified

Astronomer CertifiedPostgresMySQLPythonSystem DistributionAirflow Helm Chart
1.10.159.6+5.7, 8.0+3.6, 3.7, 3.8Debian 10 (Buster)Any
2.0.09.6+8.0+3.6, 3.7, 3.8Debian 10 (Buster)0.18.6+
2.0.29.6+8.0+3.6, 3.7, 3.8Debian 10 (Buster)0.18.6+
2.1.09.6+8.0+3.6, 3.7, 3.8Debian 10 (Buster)0.18.6+
2.1.19.6+8.0+3.6, 3.7, 3.8, 3.9Debian 10 (Buster)0.18.6+
2.1.39.6+8.0+3.6, 3.7, 3.8, 3.9Debian 10 (Buster)0.18.6+
2.1.49.6+8.0+3.6, 3.7, 3.8, 3.9Debian 10 (Buster)0.18.6+
2.2.09.6+8.0+3.6, 3.7, 3.8, 3.9Debian 11 (Bullseye)0.18.6+
2.2.19.6+8.0+3.6, 3.7, 3.8, 3.9 (Default)Debian 11 (Bullseye)0.18.6+
2.2.29.6+8.0+3.6, 3.7, 3.8, 3.9 (Default)Debian 11 (Bullseye)0.18.6+
2.2.39.6+8.0+3.6, 3.7, 3.8, 3.9 (Default)Debian 11 (Bullseye)0.18.6+
2.2.49.6+8.0+3.6, 3.7, 3.8, 3.9 (Default)Debian 11 (Bullseye)0.18.6+
2.2.59.6+8.0+3.6, 3.7, 3.8, 3.9 (Default)Debian 11 (Bullseye)0.18.6+
2.3.09.6+8.0+3.6, 3.7, 3.8, 3.9 (Default)Debian 11 (Bullseye)0.18.6+

For more detail on each version of Astronomer Certified and instructions on how to upgrade, refer to Upgrade Apache Airflow.

Note: While the Astronomer Certified Python Wheel supports Python versions 3.6, 3.7, and 3.8, Astronomer Certified Docker images have been tested and built only with Python 3.7. To run Astronomer Certified on Docker with Python versions 3.6 or 3.8, you can create a custom image with a different Python version specified. For more information, read Change Python Versions.

Note: MySQL 5.7 is compatible with Airflow and Astronomer Certified 2.0 but it does NOT support the ability to run more than 1 Scheduler and is not recommended. If you'd like to leverage Airflow's new Highly-Available Scheduler, make sure you're running MySQL 8.0+.