Skip to main content
Version: 0.30

Version compatibility reference for Astronomer Software

Astronomer Software ships with and requires a number of adjacent technologies that support it, including Kubernetes, Helm, and Apache Airflow itself. This guide provides a reference of all required tools and versions for running Astronomer Software. This guide also includes a version compatibility reference table for running Astronomer Certified outside of the context of the Astronomer platform.

While the tables below reference the minimum compatible versions, we typically recommend running the latest versions of all tooling if and when possible.

Astronomer Software

Astronomer PlatformKubernetesAstro CLIPostgresPythonAstronomer Certified / Astro RuntimeHelm
v0.251.17, 1.18, 1.19, 1.20, 1.210.25.x9.6+3.6, 3.7, 3.8, 3.9 (requires AC 2.2.0+)All supported Certified versions*3.6
v0.281.19, 1.20, 1.21, 1.221.0.x - 1.1.x9.6+3.6, 3.7, 3.8, 3.9 (requires AC 2.2.0+)All supported Certified versions3.6
v0.291.19, 1.20, 1.21, 1.22, 1.231.3.x9.6+3.6, 3.7, 3.8, 3.9 (requires AC 2.2.0+)All supported Certified and Runtime versions3.6
v0.301.19, 1.20, 1.21, 1.22, 1.231.4.x - 1.6.x9.6+3.6, 3.7, 3.8, 3.9 (requires AC 2.2.0+)All supported Certified and Runtime versions3.6

For more detail about the changes in each Astronomer Software release, see the Astronomer Software Release Notes.

All currently supported Astronomer-distributed images are compatible with all versions of Astronomer Software. Astronomer Certified and Astro Runtime maintenance is independent of Software maintenance. For more information, see:

Note: Due to the deprecation of Dockershim, Azure does not support private CAs starting with Kubernetes 1.19. If you use a private CA, contact Astronomer support before upgrading to Kubernetes 1.19 on AKS.

Note: While Astronomer v0.25 is compatible with Astronomer Certified 2.2.0, support for the Airflow triggerer is available only in Astronomer v0.26+. To use deferrable operators, which require the Airflow triggerer, you must upgrade.

Kubernetes version support policy

In general, Astronomer Software will support a given version of Kubernetes through its End of Life. This includes Kubernetes upstream and cloud-managed variants like GKE, AKS, and EKS. When a version of Kubernetes reaches End of Life, support will be removed in the next major or minor release of Astronomer Software. For more information on Kubernetes versioning and release policies, refer to Kubernetes Release History or your cloud provider.

For more information on upgrading Kubernetes versions, follow the guidelines offered by your cloud provider.

Astronomer Certified

Astronomer Certified images have the following version dependencies:

Astronomer CertifiedPostgresMySQLPythonSystem DistributionAirflow Helm chart, 3.7, 3.8Debian 10 (Buster)0.18.6+, 3.7, 3.8, 3.9Debian 10 (Buster)0.18.6+, 3.7, 3.8, 3.9Debian 10 (Buster)0.18.6+, 3.7, 3.8, 3.9Debian 10 (Buster)0.18.6+, 3.7, 3.8, 3.9 (Default)Debian 11 (Bullseye)0.18.6+, 3.7, 3.8, 3.9 (Default)Debian 11 (Bullseye)0.18.6+, 3.7, 3.8, 3.9 (Default)Debian 11 (Bullseye)0.18.6+, 3.7, 3.8, 3.9 (Default)Debian 11 (Bullseye)0.18.6+, 3.7, 3.8, 3.9 (Default)Debian 11 (Bullseye)0.18.6+, 3.7, 3.8, 3.9 (Default)Debian 11 (Bullseye)0.18.6+

For more detail on each version of Astronomer Certified and upgrade instructions, see Upgrade Apache Airflow.

Note: While the Astronomer Certified Python Wheel supports Python versions 3.6, 3.7, and 3.8, Astronomer Certified Docker images have been tested and built only with Python 3.7. To run Astronomer Certified on Docker with Python versions 3.6 or 3.8, you can create a custom image with a different Python version specified. For more information, read Change Python Versions.

Note: MySQL 5.7 is compatible with Airflow and Astronomer Certified 2.0 but it does NOT support the ability to run more than 1 scheduler and is not recommended. If you'd like to leverage Airflow's new Highly-Available scheduler, make sure you're running MySQL 8.0+.